How To Troubleshoot Disk2vhd Error If Snapshot Volumes Are Incorrect
Here are some simple steps that can help you fix disk2vhd error when volume write setting is incorrect.
PC running slow?
I faced the same issue with Windows 10 version 1909 (codename 19H2 / build 18363), so it might be the same underlying issue with later versions of Windows 10.
I found that Disk2VHD was unable to P2V rebuild the volume (about 500MB in a small case) and create an EFI volume (about 100MB in my case) using volume snapshots.
Why do I get error snapshot in disk2vhd?
The error is the manufacturer’s own description of the DISK2VHD error occurring with my XP shadow copy functions. This error is not limited to DISK2VHD software and can appear in anything that uses shadow duplication features. In most cases, these tools are utilities.
After numerous bug fixes, unsuccessful attempts to resolve the underlying VSS issue, I found that the above issues are currently preventing P2V from working with VSS and all VSS-related errors in the current event log.
Then I just excluded 500MB from the recovery volume and set up a P2V process using VSS. Hyper-V also starts well in2016 (Hyper-V VM rebooted once, maybe twice before Windows, but booted probably because my P2V was a password protected laptop with Bitlocker)
Microsoft has released this utility called disk2vhd. This executable file is designed to facilitate the conversion of a Windows medical system into a virtual hard disk.
Disk2vhd is indeed a utility that creates virtual hard disks (Microsoft virtual machine disk format) of physical disks for use in Microsoft Virtual PC or Microsoft Hyper-V virtual machines (VMs). The difference between Disk2vhd and other physical and virtual tools is that Disk2vhd can run on the system as it is on the network. Disk2vhd uses the Windows volume snapshot feature, introduced in XP, to create consistent, timed snapshots of volumes that most people want to include in their conversion.
The client requested assistance in identifying errors while trying to use the utility. It was impossible to try to take a picture, because theOvana is an indescribable mistake. After doing a little detective work, I found that disk2vhd that.exe has problems due to the need for the Volume Shadow Copy Service (VSS). This is how I found and fixed the VSS errors.
First of all, the principle of Event Viewer is to solve problems in Windows. Open it and check the mailing lists of the app. Check for a VSS error. Open the Services control (run services.msc) and restart the Volume Shadow Copy service on your computer. You can view the following:
PC running slow?
ASR Pro is the ultimate solution for your PC repair needs! Not only does it swiftly and safely diagnose and repair various Windows issues, but it also increases system performance, optimizes memory, improves security and fine tunes your PC for maximum reliability. So why wait? Get started today!
Ignore this link for more information. It doesn’t really help. Instead, write down Event ID 12302 and go to Microsoft Knowledge Base Article 907574:
When using the backup feature in Windows XP or Windows XP Tablet PC Edition 2005, you will get the perfect Volume Shadow Copy Service error message and appointment 5013 or event 12302.
This issue occurs because the Location registry entry is invalid or is missing from the following registry subkey:
HKEY_LOCAL_MACHINE SYSTEM CurrentControlSet Control ContentIndex Catalogs
This processThis problem occurs after uninstalling a program contained in this registry subkey, but the location information for which has been removed from the PC registry subkey.
Follow the instructions to fix or remove invalid subkeys. He worked on the one-man system.
Another troubleshooting method is to use vssadmin to validate VSS operations.
Enter “vssadmin contact list authors” at the command line and you will also see the following:
This brought me the same event ID, but Microsoft suggested a different solution. KB article 940184 discusses how to remove and reset a loser in COM and VSS:
This issue can occur if the following registry key is malicious: HKEY_LOCAL_MACHINE SOFTWARE Microsoft EventSystem 26c409cc-ae86-11d1-b616-00805fc79216 Subscriptions
Your solution is somewhat unique, so here is a short version of the batch data file that should make your job easier.
Also copy and paste the following commands into this file named VSSrepair.bat and then run them to actually run the commands from 940184:
@echo https: // www de
SEM
REM.flyingpenguin.com
SEM
REM Batch File to Restore Volume Shadow Copy Installation (VSS)
REM based on https://support.microsoft.com/kb/940184
SEM
Echo — WARNING !! A WARNING !! A WARNING !! A WARNING !!
Echo.
echo — Only work with these admin benefits
Echo.
echo — DO NOT USE on Windows Vista, Windows Server 2008,
echo — or Windows installation versions. Windows Vista and
echo — Server 2008 uses manifest-based feature installation;
echo — The manual for the components disc can cause serious errors
echo — and requires Windows reinstallation to fix the solution permanently.
Echo.
Echo — WARNING !! A WARNING !! A WARNING !! A WARNING !!
SEM
Suspend
cd / d% windir% system32
Echo.
Turn off vss
pure swprv
regsvr32 ole32.dll
regsvr32 oleaut32.dll
regsvr32 / i eventcls.dll
regsvr32 vss_ps.dll
vssvc / register
regsvr32 / je swprv.dll
regsvr32 es.dll
regsvr32 stdprov.dll
echo — vssui.dll is definitely for Windows 2003 only. This bug has been fixed in XP
regsvr32 vssui.dll
regsvr32 msxml.dll
regsvr32 msxml3.dll
echo — msxml4.dll is optional and therefore may be lostn. Ignore this error
regsvr32 msxml4.dll
Break
The knowledge base then recommends that you enter “authors from the vssadmin directory” when prompted. Success means you actually see a list like this:
Hope this saves you some time. There might actually be more problems with VSS, but some of these two methods worked for me.
Upgrade to: If Visio is installed, you may need to remove the following registry entry for your PC
How to fix it.
Share my experience for fixing all kind of technical problems.
Monday, May 15, 2017
Disk2VHD error snapshotting volumes — Fixed

I opened the Windows event log viewer and found several errors of VSS.
One of them was Event ID 22 —
Volume Shadow Copy Service error: A critical component required by the Volume Shadow Copy service is not registered. This might happened if an error occurred during Windows setup or during installation of a Shadow Copy provider. The error returned from CoCreateInstance on class with CLSID <79079d5c-ef20-4952-b9fc-cfd443b38641>and Name SW_PROV is [0x80040154, Class not registered].
Run RegEdit and open the registry path
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\VSS\Providers
There was a registry key of
The backup software Acronis is no longer installed on the server. After I deleted the registry key of
Hopefully this information can save your time.
12 comments:
Exact same issue and this resolved my error. Make sure to restart the VSS service after you delete the registry entry.
I still have the same mistake yet I have no other provider in my registry
This didnt work for for me either but I unselected "use volume shadow copy and it worked for me 🙂
Error snapshotting volumes disk2vhd как исправить
Trying to run disk2vhd on a SBS 2011 with 2 partitions, getting the "Error snapshotting volumes". The server is a VMWare VM (yes I know its doggy to have SBS as a VM (this isn’t my setup, we are just migrating users and files from this server))
Event log has these:
"Volume Shadow Copy Service error: Unexpected error querying for the IVssWriterCallback interface. hr = 0x80070005, Access is denied. . This is often caused by incorrect security settings in either the writer or requestor process."
For the System Writer, DHCP Jet Writer, SPSearch4 VSS writer, TS Gateway Writer, NPS VSS writer.
I have attempted:
- Only selecting one or the other of the two partitions
- I am running disk2vhd "as administrator" with a domain admin account/local admin.
- Created an AD group "vssregistrygroup" added this group to registry HKLM\System\CurrentControlSet\Services\VSS\VssAccessControl as a dword "DOMAIN\vssregistrygroup" with value 1
- Added the above group with full permission to HKLM\System\CurrentControlSet\Services\VSS\Diag\
- I’ve completed the SharePoint configuration (SBS server).
- Restarted the server
- I’m physically located hours away from the server so I cant boot into WinPE or anything like that to run disk2vhd from there.
- Restarted volume shadow copy service.
- vssadmin list writers shows no errors or warnings on any writers.
- Added my admin account in dcomcnfg.exe to component services\computers\my computer — com security — Access permissions with local and remote access.
I’ve been searching the error messages for hours already, please don’t respond with a quick link to something suggesting one of the above things that I’ve already tried. By all means, if you have a link suggesting something that I haven’t actually tried, I am all ears.
- Edited by Trana010 Friday, August 23, 2013 2:03 AM
- Moved by Santosh Bhandarkar Tuesday, August 27, 2013 6:34 AM Moved from Server General Forum, OS in question is SBS
Answers
It seem a good utility. I might give it a try to export the disk.
I was more talking about vconverter because I got serious problem migrate a DC into virtual without it in the past. I tried with XenServer tool, and at that time the tool was not enougth mature for a good shot. I finished to use vconverter and after redo a transfert into the good format (xenserver use the vhd standard, so it’s not a big move in the end)
In worst case I would use the vmware tool and re-image the disk after. (but it will take some time to do)
MCP | MCTS — Exchange 2007, Configuring | Member of TechNet Wiki Community Council | French Moderator on TechNet Wiki (Translation Widget)
- Proposed as answer by Alex Lv Sunday, September 1, 2013 1:32 AM
- Marked as answer by Trana010 Thursday, September 12, 2013 1:49 AM
All replies
What hypervisor you use ? Installing the Integration tool will make you able to make a snapshot from the hypervisor directly in most case. (and you can copy the file directly in msot case)
MCP | MCTS — Exchange 2007, Configuring | Member of TechNet Wiki Community Council | French Moderator on TechNet Wiki (Translation Widget)
Ironically, I am running into the same exact issue right now, except on SBS 2008. I was doing some researching and came across you post.
One other thing I tried is boot into DSRM and run Disk2vhd from there, but now getting another error and VSS complaining that the server is in DSRM in App Log, where before when I stopped AD services it was complaining with other even id, suggesting to go into DSRM mode and run from there.
I am also away from the server and doing this remotely. Your suggestion with WinPE or maybe Hiren’s Boot CD is not a bad idea. I can get to the server within an hour or so. Will this make a difference on where the Disk2vhd is ran from?
My next step was to run Symantec System Recovery or Acronis product to do the P2V conversion to Hyper-V. Any other thoughts? Thanks
Yagmoth, as mentioned, the server in question is hosted on VMware, so yes, I might need to look into that approach of exporting the VM from there, I was just hoping to avoid the conversion hassle (I need to mount it in Hyper-V later on) by using disk2vhd on the original VMware VM.
Alex: The WinPE isnt my own idea, I did come across a thread somewhere else where someone had supposedly done this on multiple SBS servers, however it wasnt 100% clear if it was on a data disk only or if he actually did it on a whole system and came out with a bootable VHD and not just a VHD to be added to another VM.
I have progressed slightly myself since my last post.
Step 1:
Had disk2vhd excluded from the antivirus real time agent. This has removed the previous event error posted above the IVssWriterCallback. I’m writing this in retrospect, but I believe this was the new error:
Volume Shadow Copy Service error: Error calling a routine on a Shadow Copy Provider <>. Routine details BeginPrepareSnapshot(<>,<>,\\?\Volume<>\) [hr = 0x800700aa, The requested resource is in use.
].
Operation:
Add a Volume to a Shadow Copy Set
Context:
Execution Context: Coordinator
Step 2:
I stopped the backup software VSS services and tried again, new event error again:
Volume Shadow Copy Service error: Error creating the Shadow Copy Provider COM class with CLSID <> [0x80070422, The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.
].
Operation:
Obtain a callable interface for this provider
Add a Volume to a Shadow Copy Set
Context:
Provider ID: <>
Class ID: <>
Snapshot Context: 4194304
Execution Context: Coordinator
Volume Shadow Copy Service information: The COM Server with CLSID <> and name SW_PROV cannot be started. [0x80070422, The service cannot be started, either because it is disabled or because it has no enabled devices associated with it.
]
Operation:
Obtain a callable interface for this provider
List interfaces for all providers supporting this context
Check If Volume Is Supported by Provider
Add a Volume to a Shadow Copy Set
Context:
Provider ID: <>
Class ID: <>
Snapshot Context: 4194304
Snapshot Context: 4194304
Execution Context: Coordinator
Provider ID:
Volume Name: \\?\Volume<>\
Execution Context: Coordinator
Got some ideas, but need to wait for the weekly backup to finish. Meanwhile, anyone have any suggestions?
Cannot convert physical disk to vhdx (Hyper-V)
100GB [unencrypted]). Here is a step-by step tutorial, on how to do it. This method was very convenient, since you are saving whole structure with full encryption and saving it to a single, expandable file (if used space is less than 700GB, the backup image will also take less space). Plus, if you want, you can attach it to your PC and use it as a virtual disk.
However, starting about two months ago, I could not copy the physical drive during the same method, always ending up with the following error:

I have tried it on another Windows 10 machine — same error.
I have also tried Disk2vhd utility from Microsoft — also getting an «Error snapshotting volumes».
I have no clue, why this happens, since the disk is the same, with the same partitions. But it does not work anymore.